I. During Free/Busy
Problem
Performing free/busy requests to Google failed with the error ‘Google.Apis.Requests.RequestError Invalid Credentials [401] Errors [ Message[Invalid Credentials] Location[Authorization – header] Reason[authError] Domain[global] ] ‘.
Cause 1
The login filled in the field Free/busy User Login is not valid
Resolution 1
Check if your user has:
- A valid account (no issue with password expired, or inactive account)
- A valid access to use G Suite Calendar
Cause 2
The login filled in the field Free/busy User Login is not valid
Resolution 2
Check if your user has:
- A valid account (no issue with password expired, or inactive account)
- Valid access to use G Suite Calendar
II. During File migration
Problem
Performing a G drive migration, you noticed the following error: “Fatal Error : Google.Apis.Requests.RequestError Invalid Credentials [401] Errors [ Message[Invalid Credentials] Location[Authorization – header] Reason[authError] Domain[global]”.
Cause 1
The migrated user does not have a valid G Suite license.
Resolution 1
- Log into admin console https://admin.google.com/AdminHome, then choose Users.
- Click on the impacted user.
In the section License check if the license allows the user to have a drive. For example, only Google Vault license assigned does not allow to have a drive.
Cause 2
The user does not have access to Drive and Docs App.
Resolution 2
- Log into admin console https://admin.google.com/AdminHome, then choose Apps.
- Click on G Suite.
The Drive and Docs App should be activated for everyone or for an organization where the impacted user is located: