Problem
While migrating a user to Office 365 or Exchange using Cloudiway, you see the following error: “Test connection Error No mailbox with such guid”.
Cause
The target email is incorrectly configured.
If the target is Office 365, the account does not have any product license (Office 365 license), and/or any Exchange license is not assigned to it (in this case, the account exists but no mailbox has been created for it).
Resolution
Assign an Exchange license to the user and restart your migration.
NOTICE: if you just created your mailbox, wait for a while until its creation on Microsoft side, then restart your migration.