You are migrating mailboxes from Google Workspace using Cloudiway to another tenant and hit the following error:
“Throttling limit reached, stopping migration” in the user migration logs.
Cause 1
Google connector: Cloudiway migrates Google Apps mail using the IMAP protocol for which Google imposes throttling limitations.
Reaching the limit triggers a safeguard that temporarily suspends the account.
See https://support.google.com/a/answer/1071518?hl=en
Typically, Google allows a download of between 2.5 and 3.5 GB of data per day after which it may disable the user account for up to 24 hours.
Cloudiway is subject to this limitation and migrates only up to the limit of data per day.
Once this volume of data is reached, the migration is put in Pending status and automatically restarts 18 hours later.
The platform usually manages to migrate up to 10 GB without stopping.
Therefore, migration more than 10-GB mailboxes may take up to 3 days to migrate.
Cause 2
Any connector: The migration engine identifies that the throughput within the last hour is too low (less than 250 items migrated) and considers it as throttling. The migration will appear in Pending status for the next 4 hours.
Cause 3
Any connector: When consecutive calls are timing out, the platform determines that the calls are throttled and automatically stops and restarts later.
Resolution
There is nothing to do: this is expected behavior.
The migration of a pending user is automatically restarted.